Minggu , November 17 2019
Home / Jaringan / Ganti DNS Otomatis di Mikrotik Berdasarkan Waktu

Ganti DNS Otomatis di Mikrotik Berdasarkan Waktu

Dengan semakin giatnya pemerintah untuk memblokir situs negatif baik itu situs porno, judi bahkan phising kita sebagai pengelola sebuah akses internet publik seperti warnet, Hostspot atau RT/RW Net wajib mengikuti kebijakan tersebut. Namun di satu sisi kita kehilangan pelanggan karena batasan ini, dan dalam hal bisnis ini adalah sebuah kerugian. Dan di sisi lain kita juga harus ikut kebijakan pemerintah serta menyelamatkan anak-anak Indonesia.

Oleh karena dual hal itu, maka kita harus bisa menjadi di tengah-tengahnya. Artinya kita juga ikut aturan pemerintah dan dilain pihak kita juga perhatikan keinginan pelanggan kita.

Nah untuk itu, saya berpikir untuk melakukan penjadwalan DNS di jaringan warnet saya. Dengan router mikrotik RB750 saya setting akses DNS Nawala ketika pukul 6 pagi dan berubah menjadi Google DNS pada jam 11 malam. Nah , antara jam 11 malam sampai jam 6 pagi biasanya untuk anak-anak jarang meng-akses internet dan di jam ini seluruh akses terbuka alias tanpa blokir.

Berikut caranya:

Masuk ke router via winbox, lalu ke System – Scripts. Tambahkan dua script berikut:

script name: bebas

/ip dns cache flush
/ip dns set servers=8.8.8.8

scrip name: proteksi

/ip dns cache flush
/ip dns set servers=180.131.144.144

Buka konsol New Terminal, paste-kan comment berikut (waktu dapat disesuaikan):

 /system scheduler add name=”perlindungan” interval=1d start-time=06:00:00 on-event=proteksi
/system scheduler add name=”pembebasan” interval=1d start-time=23:00:00 on-event=bebas

Lalu kita memaksakan komputer klien untuk menggunakan DNS yang kita setting di mikrotik, sekalipun merekan mengubahnya.

Buka New Terminal, lalu paste-kan comment berikut:

 /ip firewall nat add chain=dstnat action=redirect to-ports=53 dst-port=53 protocol=udp disabled=no
/ip firewall nat add chain=dstnat action=redirect to-ports=53 dst-port=53 protocol=tcp disabled=no

Sekarang kita telah selesai men-setting penjadwalan gantti dns otomatis di mikrotik. Silahkan lihat log untuk melihat script bekerja pada waktu yang telah kita tentukan.

About Riza Mirza

Riza Mirza, seorang web developer dan internet marketer dari Lhokseumawe, Aceh. Juga mahasiswa Universitas Al Muslim Peusangan.

Lihat Juga

Review Paket Internet Unlimited Tri 2017

Review Paket Internet Unlimited Tri 2017

Sebelumnya saya agak sedikit kesal karena lambatnya akses koneksi wifi dari wifi.id. Mungkin saja ini …

4 comments

  1. Sukses Selalu…. Terimakasih postingannya Mantaabzzz…

  2. Saya tertarik dengan postingan anda ini, informasi DNS yg sangat berguna sekali.
    Saya juga mempunyai tulisan yang sejenis yang bisa anda kunjungi di
    Informasi Seputar Cisco Gunadarma

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *